Новые торренты

Самые скачиваемые

5 C

5

 

mag1976 ®

Longevity:
9 years 7 months
Posts:
5

Прошу помощи в прописи сетевой карты в dsdt! Случилось так, что у меня вышла из строя встроенная сетевая карта, c которой интернет работал просто отлично, и я заменил ее на внешнюю Realtek RTL-8169 Gigabit Ethernet, в результате на винде и линуксе, установленных на моем кампе, после настройки интернет работает безо всяких проблем, а вот под маком никак не удается заставить его работать полноценно — после долгих попыток нашел более-менее рабочий кекст (одна из разновидностей AppleRTL8169Ethernet.kext с osx86.net), с которым после перезагрузки кампа интернет нормально подхватывается и какое-то (разное по продолжительности, от 10-15 минут до 4-5 часов) время работает, но потом тихонько отваливается, и для повторного подключения нужна только перезагрузка! Что я уже только не делал — и настройками возился, перепробовал вроде как все возможные варианты — и с 10baseT/UTP, 100baseTX и 1000baseT, c разными дуплексами, размером пакетов, перепробовал массу различных кекстов (в т.ч. родные с сайта производителя) — результат к лучшему изменить не удается... После этих попыток я решил попытаться прописать сетевую в dsdt, может, хоть после этого появится какой-то эффект! Сохранил свой снимок ioreg и, соответственно ему, прописал свои значения в dsdtse в dsdt.dsl, но вот скомпилировать не получается, постоянно выбрасывает такую ошибку:
Error 4069 - Could not open file "/Users/oleg/Library/Application Support/EvOSoftware/DSDT/DSDTFiles//Users/oleg/Documents/DSDT.aml" (No such file or directory)
/Users/oleg/Library/Application Support/EvOSoftware/DSDT/DSDTFiles/dsdt.dsl 2617: Device (ethernet)
Error 4096 - syntax error, unexpected PARSEOP_NAMESEG, expecting ')' ^
/Users/oleg/Library/Application Support/EvOSoftware/DSDT/DSDTFiles/dsdt.dsl 3349: Scope CreateWordField (Arg0, One, ISRS)
Error 4096 - syntax error, unexpected PARSEOP_SCOPE, expecting $end ^
Вот снимок ioreg c моего кампа:
Скачать iMac-Oleg.ioreg
Вот исправленный соответственно ему фрагмент секции dsdt:
Device (ethernet)
{
Name (_ADR, Zero)
Method (_DSM, 4, NotSerialized)
{
Store (Package (0x18)
{
"AAPL,slot-name",
Buffer (0x09)
{
"Built In"
},
"built-in",
Buffer (One)
{
0x00
},
"device_type",
Buffer (0x09)
{
"Ethernet"
},
"device-id",
Buffer (0x09)
{
0x69, 0x81, 0x00, 0x00
},
"compatible",
Buffer (0x2D)
{
"pci10ec,8169, pciclass, 020000"
},
"model",
Buffer (0x19)
{
"Ethernet Network Adapter"
},
"IOName",
Buffer (0x0D)
{
"pci10ec"
},
"name",
Buffer (0x0D)
{
"pci10ec"
},
"revision-id",
Buffer (0x04)
{
0x10, 0x00, 0x00, 0x00
},
"subsystem-id",
Buffer (0x04)
{
0x69, 0x81, 0x00, 0x00
},
"subsystem-vendor-id",
Buffer (0x04)
{
0xEC, 0x10, 0x00, 0x00
},
"vendor-id",
Buffer (0x04)
{
0xEC, 0x10, 0x00, 0x00
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}
Вот мой файл dsdt.dsl c фраментом c прописанной сетевой (Device (P0P1)):
Скачать DSDT.dsl
Помогите, пожалуйста, разобраться с прописью сетевой, а то я уже совсем запутался, что я могу еще исправить, а интернета очень не хватает для полноценного пользования системой! :(
ACER Aspire M3641 M/b: MCP73PV nVIDIA nForce 7100-630i; DualCore Intel Pentium E5200, 2500 MHz Socket: 775 LGA M&K: PS/2; Hitachi HDP725032GLA380 ATA Device (320 Gb, 7200 RPM, SATA-II); BIOS: AMI v. R01-C2L 04/23/2009 MMX, SSE, SSE2, SSE3, SSSE3, EM64T; HL-DT-ST DVDRAM GH40F ATA Device RAM: 4Gb DDR2-800 SDRAM; Video: NVIDIA GeForce GT 240 (512 MB); Realtek RTL-8169 Gigabit Ethernet; Audio: nVIDIA HDMI @ nVIDIA MCP73
[Profile]  [PM] 

mizar

Longevity:
10 years
Posts:
937

драйвер для 8169 должен быть на сайте Realtek, когда пользовался подобными карточками, там брал, работало без dsdt
но, карта PCI работала стабильно, а карта PCI-E иногда при старте не определялась, после перезагрузки появлялась
Железо:
GA-Z77X-D3H
i5 3550,
DDR3 4x4Gb Samsung 1333@2000,
MSI GTX 670,
SATA: WD10EARS x2 + WD20EARX, DVD-RW PIONEER DVRS19LBK, NOC-MSATA-60G.
Wi-Fi: TP-LINK TL-WDN4800 (AR9380)
DELL UltraSharp U2412M(1920x1200) .
10.10
[Profile]  [PM] 

mag1976 ®

Longevity:
9 years 7 months
Posts:
5

Пробовал завести родными драйверами с сайта Realtek, но та же самая история - карточка определяется и какое-то время, разное по продолжительности, работает, но в итоге интернет все равно отваливается, возня с настройками соединения не помогает, вот почему мне и пришла идея прописать карту в dsdt, может, хоть это поможет!
ACER Aspire M3641 M/b: MCP73PV nVIDIA nForce 7100-630i; DualCore Intel Pentium E5200, 2500 MHz Socket: 775 LGA M&K: PS/2; Hitachi HDP725032GLA380 ATA Device (320 Gb, 7200 RPM, SATA-II); BIOS: AMI v. R01-C2L 04/23/2009 MMX, SSE, SSE2, SSE3, SSSE3, EM64T; HL-DT-ST DVDRAM GH40F ATA Device RAM: 4Gb DDR2-800 SDRAM; Video: NVIDIA GeForce GT 240 (512 MB); Realtek RTL-8169 Gigabit Ethernet; Audio: nVIDIA HDMI @ nVIDIA MCP73
[Profile]  [PM] 

mag1976 ®

Longevity:
9 years 7 months
Posts:
5

Драйвера с сайта Реалтек (сейчас стоит RTGMac v.2.0.6) стабильно работают только при загрузке с флагом cpus=1, при загрузке с двумя ядрами уже перепробовал множество различных кекстов, прописывал карту в dsdt - история та же - через какое-то время сеть отваливается... Все остальное работает отлично. Посоветуйте, каким способом можно заставить работать сеть при загрузке с двумя ядрами? Потому что все-таки при работе с одним периодически тормоза очень заметны...
ACER Aspire M3641 M/b: MCP73PV nVIDIA nForce 7100-630i; DualCore Intel Pentium E5200, 2500 MHz Socket: 775 LGA M&K: PS/2; Hitachi HDP725032GLA380 ATA Device (320 Gb, 7200 RPM, SATA-II); BIOS: AMI v. R01-C2L 04/23/2009 MMX, SSE, SSE2, SSE3, SSSE3, EM64T; HL-DT-ST DVDRAM GH40F ATA Device RAM: 4Gb DDR2-800 SDRAM; Video: NVIDIA GeForce GT 240 (512 MB); Realtek RTL-8169 Gigabit Ethernet; Audio: nVIDIA HDMI @ nVIDIA MCP73
[Profile]  [PM] 

mag1976 ®

Longevity:
9 years 7 months
Posts:
5

Разобрался! Как оказалось, в моем случае соответственно хаку cpus=1 fix нужно было всего лишь вручную немного подправить dsdt, вот так:
до:
Processor (P001, 0x01, 0x00000810, 0x06) { }
Processor (P002, 0x02, 0x00000810, 0x06) { }
после:
Processor (P001, 0x01, 0x00000810, 0x06) { }
Processor (P002, 0x02, 0x00000000, 0x00) { }
И после этого сетевая заработала без проблем с запущенными двумя ядрами процессора!
ACER Aspire M3641 M/b: MCP73PV nVIDIA nForce 7100-630i; DualCore Intel Pentium E5200, 2500 MHz Socket: 775 LGA M&K: PS/2; Hitachi HDP725032GLA380 ATA Device (320 Gb, 7200 RPM, SATA-II); BIOS: AMI v. R01-C2L 04/23/2009 MMX, SSE, SSE2, SSE3, SSSE3, EM64T; HL-DT-ST DVDRAM GH40F ATA Device RAM: 4Gb DDR2-800 SDRAM; Video: NVIDIA GeForce GT 240 (512 MB); Realtek RTL-8169 Gigabit Ethernet; Audio: nVIDIA HDMI @ nVIDIA MCP73
[Profile]  [PM] 
Display posts from previous:    

The time now is: Today 02:49

All times are GMT + 4 Hours



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum